


Fiji Is Just Image)

(batteries included)
Fiji for users

one free software package
many bundled plugins
advanced scripting languages
tutorials/documentation
coherent menu structure

Fiji for developers
version control

build system
open source




Some Image) History
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Apple Mac only
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... and then much more



Batteries Included !
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Java

One software package

Java Runtime + Java3D,
for Windows, Mac, Linux

32/64-bit
Image)A

Plugins!

http://fiji.sc/

on | Content

Fiji Is Just ImageJ

Fiji is an image processing package based on Image) &.

Far users, Fiji is easy to install and update, bundles a set of
plugins in a coherent menu structure (and updatable), along
with comprehensive documentation.

Far developers, Fiji as an open source project is hosted on a

Git source version cantrol repository &, with access to the
source code of all internals, libraries and plugins, and eases

the development and scripting of plugins.
Download Fiji now °

The Sirnple Meurite Tracer allows you to segment linear structures in
30 images by marking both ends in 30 and letting the tracer work

NEWS out the rest.

* 2010-03-01 - Fiji featured in Nature Methods review on visualization

* 2010-02-04 - Weh Statistics and Fiji usage map

» 2010-01-21 - The Fiji Wiki got a new look

® 2008-12-17 - Mew Plugin: RATS (Robust Autornatic Threshold Selection)
« 2008-12-04 - Updated TrakEM2 to version 0.7 m


http://fiji.sc/

F

1ji Updater

Up-to-date check E3
] You have not checked for updates yet.
= Would you like to check now?
Yes, please Never Remind me later Fiji Updater
Mame StatusAction
ij.jar Update it
plugins/AnalyzeSkeleton_.jar Update jt
plugins/Auto_Threshold.jar Update jt
plugins/Fiji_Plugins._jar Update it
plugins/Fiji_Updater.jar Update it
plugins/Sstack_Manipulation.jar Update jt
plugins/stitching__jar Update it
plugins/ TrakEM2_.jar Update it
plugins/VIB_.jar Update jt
plugins/bUnwarp]_.jar Update it
plugins/loci_tools.jar Update it
plugins/ mpicbhg_.jar Update jt
plugins/register_virtual_staclk_slices.jar Update it
jars/dojure-contrib_jar Update it
Jjars/ clojure.jar Update it
Apply changes Advanced mode Cancel




Script Editor

_Fll_g____ Edit lmage Frocess Analze Flugins Wiindowe Help
Hew ~ Image... Strg+ M e
Qpen. .. Strg+ O Text Window strg+ Umschalt+ M
Dpen Mext strg+ Umschalt+ O Internal Clipboard !

Jpen hamples — Systemn Clipboard strg+Umschalt+4
Dpen Eecent S ;
SCHpt
lmport s
AP | =144
Close atrg+ TrakEM2 ifram template)
Sawe Strg+5 Fiji Tutarial
Save A 5
F.ewert Strg+F
Fage Setup...
Print. .. Strg+F
It




Script Editor

File Edit Options L_imm { Run Breakpoints
1 0 Java

) Javascript

) Python Edit EUTAs Text py

2 Ruby File Edit Options Language Run Ereakpoints

2 Clojure 1 dmport jarray |~

) Matlab 2 from java.awt dimport Font, Henu, MenuItem

© BeanShell 3 from :!aua.am.gwent '!mpurt LctionListener 3
4 from java.awt.image import IndexColorModel

® Mone 5
6 # (all this script to show the current Lookup Takle in an editor.
7 # The user can edit 7r, and call Lookup Table=Ser Lookup Takle afre
3 # the nuwbers,
o
10 def editLUTASText
11 image = WindowManager.getCurrentInage’)
12 if image == None:
13 Il.errori'Need an image')
14 return
15 ip = image.getProcessori)
1a Ch = ip.getiurrentColorModel )
17 if not hasattricm, 'getMapsize'):
15 Il.errori'Need an 8-hit color image')

.............................................................................................................................................................. 19 return
20 |
1 SiFp = rm.apTManSize Bl
1] T [ []




Advanced Users: Scripting

Why not use Image)'s macro

” 2
. ? Shon language?
. ' « More Power
JRuby . Faster

. O Clojure e Quicker to test ideas
¢ * Full access to Java classes

e Javascript = * Many users know Python, Ruby,
Javascript
« BeanShell 9

Example: Fiji Logo 3D - you
cannot do that with macro
language



Fiji fosters
collaboration and reuse

TrakEM?2

/

3D Viewer

T~

Feature Extraction

S

S

Stitching 2D/3D

4

Simple Neurite Tracer

bUnwarp]

See also http://fiji.sc/#Projects


http://fiji.sc/#Projects

Working together:

Version Control

“before”

See also http://f

iji.sc

/Git

I\

“after”

herge branch ‘master' of pacific. mpi-chy.de:/sre/gitiiji
b, Merge commit ‘origin/master’
® Move sources for fiji-scripting jar into their own directary

erge branch ‘junit’

WIB unit tests: do not includa juni
® Add the submodule "junit”

® Fiji Build {Copy.Jar): do not be confused by variahles
Fiji Build: expand variakles in the target names, too
Fized concurrent modification problem in interpreter inst
kerge branch 'master’ of git+sshe/cardona@pacific. mpi-
Removed singleton-status management from BSH_Interp
Add a simple interface for reporting bugs in Fiji.

Run the JUnit tests in the VIE submodule

terge branch ‘mark’

Fix refreshing scripts in headless mode

terge commit ‘origin‘master'

Add "Name Landmarks and Register” to the menu

tadified the plugin "bUnwarpd "

Remove obsolete reader

Update 10 new hio-formats version

Remove last sign of the artist formerly known as 'Fake’
Finally update java'wingd to the version with correct ex
Ahstract Interpreter: leave the Tah key alane when not
Revert "Upgrade to the 1.2.0 version of JRuby"
Upgrade to the 1.2.0 version of JRuby

terge commit ‘origin‘master'

Build.sh: detect when we are on a B4-hit platform
Update the submaodule "ImageJa"

Update the submodule "VIB"

ignacio <ignacio@asclepio.ii.uames>

tark Longair <mhl@pobox.coms

Johannes Schindelin <johannes.schindelin@gm<.des
Johannes Schindelin <johannes.schindelin@gmxdes
Johannes Schindelin <johannes.schindelin@gmx.dex
Johannes Schindelin <johannes.schindelin@gms<.de=
Johannes Schindelin <johannes.schindelin@gmx.de>
Johannes Schindelin <johannes.schindelin@gm<.des
albert Cardona <acardona@ini.phys.ethz.chs

Albert Cardona <acardona@ini.phys.ethz.che

alhert Cardona <acardona@iniphys.ethz.ch

tark Longair <mhl@pobox.coms

tark Longair <mhl@pobox.coms-

rark Longair <mhl@pobox.coms

Johannes Schindelin <johannes.schindelin@gmx.dex
tdark Longair <mhl@pobox.coms

tark Longair <mhl@pobox.coms

ignacio <ighacio@asclepio fiuam. es=

Johannes Schindelin <johannes.schindelin@gmxdes
Johannes Schindelin <johannes.schindelin@gmx.dex
Johannes Schindelin <johannes.schindelin@gms<.de=
Johannes Schindelin <johannes.schindelin@gmx.de>
Johannes Schindelin <johannes.schindelin@gmx<.des
tdark Longair <hMark.Longair@ed.ac.uks=

rdark Longair <kdark.Longair@ed.ac.uk=

tdark Longair <Mark.Longair@ed.ac.uk=

Johannes Schindelin <johannes.schindelin@gmx.de>
tark Longair <Mark Longair@ed.ac.uks=

tdark Longair <hMark.Longair@ed.ac.uks=


http://fiji.sc/Git

Fiji Usage

Fiji usage map

| Karte | Satelit | Hybid | Gelinde |

= B

This page was produced using GeoLite data created by MaxMind, available from MaxMind. downloaded from
ipinfodb.com



Purpose:
Quantitative Image
Processing

- We want answers, not pretty pictures

* Processing images means stripping away information,
never adding information. We need to be careful to strip
away information we do not want.

« At the end of the day, we want to convincing evidence.
That means statistics.

 |[f we know how we want to analyze the images, we have
a better idea how to prepare the samples and how to
obtain the images.



Getting started.:

The main window

s 00 i _ox
~Na

File Edit lmage Frocess Analyze Flugins Wfinc o HEIp|

Dev [ Stk | LUT

Tools 8 Q||| ~<| 4|+~ A& |@]_|® /14|86 |»

Image] 1.42m/fJava 1.6 0_16 [22-hit] (&¢1& commands, 27 macros)

Status Bar

See also http://fiji.sc/Getting started


http://fiji.sc/Getting_started

Getting started.:

Overview of the menus

File Edit lmage Frocess Analkyze Flugins LN fukts Help

A f A ? A A ?
I Help, Links
Windows

Plugins, Macros
and Utilities

Statistics

Image filters

Visualization parameters

Selection/ROI handling

File input/output

See also http://fiji.sc/Getting started


http://fiji.sc/Getting_started

Getting started.:

Tools, alternate tools & options

e Click on tool icons to switch to another tool

» Right-click on the little red arrows to select alternate tools:

File Edit lmage Process Analyze Plugins Wi oy Help|
B olclol-<lsl+/<ala]oO® gla]a] [»
"Ra ~ Rectangle Tool

 |Rounded Eectangle Tool

Dev | 5tk | LUT

gular selections (right click to switch)

» Double-click on tool icons to open option dialogs:

Selection Brush [x

|_|Enat:|IE Selection Brush |

Size: |10 pixels

0]4 | Cann:el|

See also http://fiji.sc/Getting started


http://fiji.sc/Getting_started

Getting started.:

The status bar (messages & progress)

* The status bar shows information about long-running processes:

File Edit lmage Frocess Analkyze Flugins finc oy Help |
B O|=|o|~| 4|\ A[A OO ®|xfsujur] 7| 4| &] | >
Feszize: 1/1 ]

 Clicking in the status bar shows information about memory consumption:

File Edit lmage Process Analyze Flugins M o HE||:II|

B ojc|ol <4 HN AR OO|®ysujw 6| 4] 8] |>

Image] 1.450; Java 1.&.0_17 [&4-hit]; 832ME of 2955ME (2 8%)

Dev | Stk

See also http://fiji.sc/Getting started


http://fiji.sc/Getting_started

Getting started.:

Image windows

clown.j jpg

See also http://fiji.sc/Getting started


http://fiji.sc/Getting_started

Getting started.:

Image types

File Edit | lmage Frocess Anahze Flugins Wi o Help
Ol | Twee — [&-bit sw|wr| § | 4| & -
w=1316, y=7 Adjust | 16-bit
Show Info..  Ctri+] ) 3z
Properties... Ctri+Shift+P | g-hit Color
Calar = ~ RGE Color
Stacks ~ || RGE Stack
Hyperstacks | H3B 5tack
Crop CTEl+5hift+ X
Cuplicate. .. Cirl+5hift+ D
Rename... Referring to menu entries:
Scale... Ctrl+E
Transform L
S > “Image>Type>RGB Color”
Chverlay |
Lookup Tahles =
Annotate =
Cirawing =
Selection =
Wideo Editing =
See also http://fiji.sc/Getting started


http://fiji.sc/Getting_started

Getting started.:

ROIs (Region of Interest, or Selection)

clown.jpg

See also http://fiji.sc/Getting started


http://fiji.sc/Getting_started

Getting started.:

Selecting an area

File Edit lmage Process Anakze Flugins il oy Help|

Ol O ||| 4| 4|s|Ala @O ® glalal |=

Dev | Stk | LUT

TEectangular™ or rounded rectangular selections (right click to switch)
L

File Edit lmage Process Analyze Flugins Mind oy Help|
I8 olzlollal+lx] Al wi| § |4 &] |=

"Re ~ Rectangle Tool gular selections (right click to switch)
| Rounded Rectangle Tool

Dev | Stk

See also http://fiji.sc/Getting started


http://fiji.sc/Getting_started

Getting started.:

Selecting an area by threshold

See also http://fiji.sc/Getting started


http://fiji.sc/Getting_started

Getting started.:

Selecting an area by threshold

v clown.jpg

205200 pixels; S-hit; 62K
: : P : ’ File  Edit | Image  Process  Anabywze  Pluging  Window Help |
) = | Twee B L] @ | De sk LoT| | 4| B >
Straight line 5E|MJUSI -~ BErightness/Cantrast. .. Ctrl+Shift+C

Show Info... Ctri+1 i owef Levvel.
Froperies. .. Ctrl+5hift+P Color Balance. ..
Color - [Threshald... Ctri+Shift+T
Stacks - Calor Threshald. ..
Hwperstacks | 5iZe...
Crop Ctrl+shiftey  -3NVas SIZe...
Duplicate..  Ctrl+Shiftap  -ne Width..

- g Rename. .. Auto Threshold
scale. .. Ctri+E Auto Local Threshold
Transfarm ~Auto Crop
Zoom o aUto Crop fguess background colon
Crhverlay L
Lookup Tables =
Annotate L
Drawing e
Selection =
Wideo Editing |

See also http://fiji.sc/Getting started


http://fiji.sc/Getting_started

Getting started.:

Selecting an area by threshold

clown.jpg E]@Er

220x200 pixels; B-hit, 62K

Default _|| Red _||

_|Dark background

,&um| ,&pplﬂ Reset| Set|

See also http://fiji.sc/Getting started
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Getting started.:

Selecting an area by threshold

clown.jpg E“E“Zr

320200 pixels; 8-hit, 62K File Edit Image Process Anakyze Plugins Wfincowe Help |
i (| tnde Ciri+2 AL @ | D s jwr) J | 4| & >
Cut Cirl+3X
Copry Ctrl+C
Copy to System
Faste Ctrl+Y

Faste Control. ..

Clear

Clear Outside

Fill Ctrl+F

Draw Ctri+D

Imvert Ctrl+Shift+1

Selection ~ Select All Cirl+ A

Qptions -~ |5elect Mone Ctrl+5hift+ A,
Festore Selection Ctri+5Shift+E
Fit spline
Fit Ellipse
Comvex Hull

Make Inwverse
Create Selection
Create Mask

Properties. ..

See also http://fiji.sc/Getting started


http://fiji.sc/Getting_started

Getting started.:

Selecting lines, points

File Edit lmage Process Anakze Flugins LI [ Help|

o14]8] |>

Dev

-

O|o|z|oF 4]+ x| ala|®|0®

Straight line selections {right click for other typoes)

Stk | LUT

File Edit lmage Process Anakze Flugins LI [ Help|

Ololz|o| <4 s Ao @O ® gla|al |=

TPoint™ or multi-point selections (right click to switch)
L

Dev

-

Stk | LUT

See also http://fiji.sc/Getting started


http://fiji.sc/Getting_started

Getting started:
ROI Manager

e

o leaf.jpg (101%)
SO7x44e pixels;, ROE, 883K

See also http://f

iji.sc

/Getting_started

ROl Manager

O0E7-0153
Q125-0070

||l || e

Add (1]
pdate
Delete
Fename...
Measure
Deselect
Properties...
Flatten [F]
More =

W Showe All
W Edlit Mode



http://fiji.sc/Getting_started

Getting started.:

Common filters

» Median filter: Process>Filters>Median...

« Gaussian Blur: Process>Filters>Gaussian Blur...
* Fourier Transform: Process>FFT>FFT
 Morphological Operators: Process>Binary>Erode
« Arithmetic Operators: Process>Math>Add...

« Arithmetics on two images: Process>Image Calculator...

e etC

See also http://fiji.sc/Getting started


http://fiji.sc/Getting_started

Getting started.:

Common filters: examples

e

clown-original.jpg
320x200_pixe|5,‘ FGE; 250k

(=) |

clown-median.jpg E“E“Zr

320}_{200 pixels; ROE; 250K

clown-gaussian-blur.jpg
320}{2(_)0 pixels; RCOB; 250K

=]} |

FFT of clown-original.j EHEHZF

S12x5 12 pixels; 8-hit; 256K




Getting started.:

Command Launcher

Command Finder

Type part of a command: [blu

Elue

Gaussian Blur...
Green Fire Blue
blue_orange_ich

[ | Show full information [ | Fuzzy matching Close when running

Run Export Close

See also http://fiji.sc/Getting started


http://fiji.sc/Getting_started

Macros:
Purpose

« Automation
 Reusable scripts
« Adding tools to the toolbar

» Adding keyboard shortcuts

See also http://fiji.sc/Macros_Intro


http://fiji.sc/Macros_Intro

Macros:
Basic concept: Variables

* A variable is a placeholder for a changing entity
 Each variable has a name

« Each variable has a value

* Values can be numeric

* Values can be text, so-called strings

» Variables can be assigned new values

See also http://fiji.sc/Macros_Intro


http://fiji.sc/Macros_Intro

Macro variables:
Setting variables

value = 2;

Intensity = 255;

title = “Hello, World!"”;
text = “title”;

text = title;

See also http://fiji.sc/Macros_Intro


http://fiji.sc/Macros_Intro

Macro variables:
Using variables

X =Y,;
text = “The title reads “ + title:
X=y*y-2*>y+ 3;

Intensity = intensity * 2;

See also http://fiji.sc/Macros_Intro


http://fiji.sc/Macros_Intro

Macro variables:

String concatenation: what is it?
And why do | need it?

number = 1;

text = “The number is “ + number:

”n {

run(“My plugin”, “does _not work=number”);

”n {

run(“My plugin”, “this_works=" + number);

See also http://fiji.sc/Macros_Intro


http://fiji.sc/Macros_Intro

Macros:
Comments

// This is a comment trying to help you to remember
// what you meant to do here:
a = exp(x * sin(y)) + atan(x *y - a);

// Code can be disabled by commenting it out
[/ Xx=y%*2;

See also http://fiji.sc/Macros_Intro


http://fiji.sc/Macros_Intro

Macros:
Built-in macro functions

print(“The title reads “ + title);
rename(title); // change the image title

/] This creates a new 640x480 color image
newlmage(“My new image”, “RGB”, 640, 480, 1);

The documentation of available built-in macro
functions can be accessed via Help>Macro Functions...

See also http://fiji.sc/Macros_Intro


http://fiji.sc/Macros_Intro

Macros:
Example: Hello, World!

/] This creates a new 640x480 color image
newlmage("World image", "RGB black", 640, 480, 1);

// make a selection in the image
makeText("Hello, World!", 50, 300);

// draw it
run("Draw");

// write text into the Log window
print("Hello, World!");

See also http://fiji.sc/Macros_Intro


http://fiji.sc/Macros_Intro

Macros:
Basic concept: User-defined functions

// Define a function for a recurring task

function newBlacklmage(title, width, height) {
// The function body is usually indented for clarity
newlmage(title, “RGB black”, width, height, 1);

}

newBlacklmage(“Tiny”, 10, 10);
newBlacklmage(“Huge”, 8000, 8000);

See also http://fiji.sc/Macros_Intro


http://fiji.sc/Macros_Intro

Macros:
Basic concept: Conditional code blocks

// If the image is not binary, abort
It (tis(“binary”)) {

exit(“You need a binary image for this macro!”);
}

/] If the code block consists of only one statement, the
// curly braces can be dropped:
It (lis(“binary”))

exit(“This image is not binary!”);

See also http://fiji.sc/Macros_Intro


http://fiji.sc/Macros_Intro

Macros:
Basic concept: Loops

// Write “Hello, World!” ten times
for(i=0:i<10; i++)
print(“Hello, World!”);

/| As before, if the code block (or “loop body”) consists
// of more than one statement, curly braces need to
// be added
for(i=0;i<10;i++) {
showProgress(i, 10); // show the progress bar

”n a

run(“Gaussian Blur...”, “radius=" + 1);

}

See also http://fiji.sc/Macros_Intro


http://fiji.sc/Macros_Intro

Macros:
The Macro Recorder

Start it with Plugins>Macros>Record...

Recorder

Fecord: Macro _|| Mame: ‘Macrn.ijm

Creale|

2|

SETECLWTITOOW], CTOWIMT=maaTdarn. Jpg J;

runi"Median...", "radius=10"};
rund"Undo");

run("Median...", "radius=5"};
selectWindow("clown-gaussian-blur.jpg");
run{"Gaussian Blur...", "sigma=3");

selectWindow("clown-median. jpg"J;
run("Capture Screen "J;

runt"Crop"l;

runi"select A11"7;

makeRectangleiO, 1, 733, 574);
run("Crop"l;

run("select A11"7;

run"&uto Crop (guess bhackground colar)™l;
runi"select A11"7;

runi"Copy To System");

See also http://fiji.sc/Macros_Intro


http://fiji.sc/Macros_Intro

Macros:
Installing Macros

Install macros with
Plugins>Macros>Install...

By using the built-in macro
function, you can install keyboard
shortcuts and tool icons.

For detalls, see the Tool Macros

section In

Help>Macros...

See also http://fiji.sc/Macros_Intro ™~

File Edit Image Process Analbyze Plugins Uiin o o Help
|:|. Oz ||~ A _4,_ il A Q, {r|Ma|:r|:|5 — |Install... Ctrl+Shift+ M
Shortcuts ~ Run. ..
Switch to alternate macro tool sets - )
Liilities -~ Edit. .
M e -~ Startup Macros. ..
Compile and Fun. .. Recard. ..
Install Plugln... _ _
Pencil Tool Options. ..
30 Wiewer Paintbrush Tool Options. ..
Analyze ~ Flood Fill Tool Options. ..
Examples —~ Set Drawing Color...
Feature Extraction -
Afout Startup Macros. ..
ImagesD |~ .
Sawe As JPEG... []]
LOC] =
Sawve Imverted FITS
Landrmarks =
Macros =
Process =
Fegistration =
Scripting =
Segmentation =
Skeleton =
Stacks =
Stitching =
Tracking -
Transform e
Hilities =



http://fiji.sc/Macros_Intro
http://rsb.info.nih.gov/ij/developer/macro/macros.html#tools

Macros:
Real-world example: keyboard shortcut

// install a keyboard shortcut: when pressing Ctrl+],
// the user is asked for JPEG quality and for a location
// to save the current image as .jpg file

macro "Save As JPEG... [J]" {
quality = call("ij.plugin.JpegWriter.getQuality");
quality = getNumber("JPEG quality (0-100):", quality);
run("lnput/Output...", "jpeg="+quality);
saveAs("Jpeg");

}

See also http://fiji.sc/Macros_Intro


http://fiji.sc/Macros_Intro

Macros:
Real-world example: action tool

/] A click on the empty rectangle will have the same
/| effect as File>Save As>/peq...

macro "Save As JPEG Action Tool - COOOR11ee" {
saveAs("|peg");

}

// A right-click on the tool icon lets the user change
/] the JPEG Quality

macro "Save As JPEG Action Tool Options" {
quality = call("ij.plugin.JpegWriter.getQuality");
quality = getNumber("JPEG quality (0-100):", quality);

run("Input/Output...", "jpeg="+quality);
}



Macros:
Examples on the Fiji Wiki

http://fiji.sc/Macros_Intro#Example_macros

Note: double-clicking the code snippets
automatically selects them for easy copying
Into the Clipboard.


http://fiji.sc/Macros_Intro#Example_macros

Macros:
Further examples & documentation

http://rsb.info.nih.gov/ij/developer/index.html

home | news | docs | download | plugins | macros/dey | list | links
Developer Resources

o Macro Language (download PDF)
o Built-in Macro Functions 2010/0223)

o Macros on Website | Search

¢ Examples
o Macro Tools
& Toolsets
o Scripting
¢ Examples

o API Documentation (v1 430

o Browsable Source (v1.43)
¢ Daily Buld Source
o Source Code Archive
o Git Version Control Repository tew

Writing ImageJ Plugins - A Tutorial
Programmer's Reference (Burger and Burge) wew
Programmung Tutonals (Albert Cardona) new
Imagmg Book (Burger and Burge)

UML Class Diagram (320KB JIpeg)
Configuration File (IT_Props. txt)

o o o o o ©


http://rsb.info.nih.gov/ij/developer/index.html

Plugins:
When macros are not enough...

Macros are quick and easy to record or write, but
* Slow

« Waste memory for more complicated tasks

« Cannot use the full functionality of Image), only what
the built-in functions offer

 Run always in foreground, blocking the computer



Plugins:
What does a plugin consist of?

Plugins are .jar files (really .zip files with a certain
structure), containing:

« One or more Java class(es) implementing the
functionality, and

* a plugins.config file defining which menu entries offer
the functionality.

« Optionally additional resources required by the plugin,
such as images or icons.

If the plugin is implemented in one Java class, and it
offers only one menu entry in the Plugins menu, it can
be offered as bare .java or .class file, too.



Plugins:
Installing plugins

File Edit lnage Process Anahze |F'Iugins Wilircl oo Help|

||:L[:l£ g:}#_f:ﬁ_ _.1,_7»\ PL Q% ﬁrr-.ﬂacrns

Shortcuts

Plugins can be

=30

installed manually Campite and ..

|In5tal| Fluglr...

by copying the .jar file into the plugins/ ...
subdirectory of Fiji and by updating the =

Examples
menus using Help>Update Menus. i
Lol

VOV VN

Landmarks
There are two easier ways, though: aros
Fegistration
. Scripting
* Plugins>Install Plugin... segmentatior
Skeleton
Stacks
. . Stitching
« Or drag 'n drop the .jar file onto the Ty
Fiji main window. Utiltes

Waolume Yiewer

MY NVVVYVVVVVVVYVV VNV




Plugins:
Where do | find new plugins?

http://rsb.info.nih.gov/ij/plugins/index.html

home | news | docs | download | plugins | macros/dey | list | links

Contents
Acquisition
Analysis
Collections
Color
Filters
Segmentation
Graphics
Input/Output
Programming Examples
Stacks
Utilities
Links to External Sites

Acquisition [top]
Hamamatsu Crea 12-bit Camera
chading Corrector
CuckTime Capture (Capture tmages using QuickTune) Updated
TWATN
JTwrain
Twain Scan Mew

sensiCam Long Exposure Camera
T i N e " e mT™T_ {1ty TtTT Oy T AT Rl


http://rsb.info.nih.gov/ij/plugins/index.html

Plugins:

Where do | find new plugins?

http://imagejdocu.tudor.lu/doku.php?id=plugin:start

navigation

= FAQ

= GUI Commands
= Keyboard Shortcuts
= Flugins

= How Tos

= Tutorials

= Known Problems
= Links

= NMacros

= [Diverse

= Wishlist

= Yideo Tutorials

= Create Mew Content

= Events

gearch

toolbox

_ [@ Show pagesource | |[Z]0ld revisions| | Export PDF |

“ou are here: Welcome to the Imaged Information and Documentation Poral » Plugins

Plugins

Table of Contents

Descriptions and downloads for Imaged plugins stored here. There are
many maore plugins in the ImageJ wehsite.

Aligning

= Align_4

v Align_FEGE_planes

= Align_Slice

= blUnwarpd: consistent and elastic registration
v Image Stahilizer

Analysis

*Plugins
=Aligning
=Analysis
=Colar
*Filters
slnput/ Dutput
sMaorphaology
sDerived images! Parametric maps
= Segmentation
= Stachks
=30 Modelling
= Utilities

s Fourier Shape Analysis

= Analyze Skeleton (20/30)

= JACoP (Just Another Co-localization Plugin)

s 30 Object Counter

= Shapelogic categorizer: Machine learning or rule based
s Frap_Morm (FRAP measurement and normalization)

» ClonalTools (analysis of mosaic images)

= FRAP Analysis (analysis of FRAP experiments)



http://imagejdocu.tudor.lu/doku.php?id=plugin:start

Fiji community:

Mailing lists:

Fiji User list <fiji-user@googlegroups.com>

Image] mailing list <imagej@list.nih.gov>

Fiji developer list <fiji-devel@googlegroups.com>
IRC (internet chat):

#fiji-devel on irc.freenode.net

See also http://fiji.sc/IRC
Documentation, information, tutorials:

http://fiji.sc/


mailto:fiji-user@googlegroups.com
mailto:imagej@list.nih.gov
mailto:fiji-devel@googlegroups.com
http://fiji.sc/IRC
http://fiji.sc/

Thanks!

Max Planck Institute CBG, Dresden
http://www.mpi-cbg.de/

Janelia Farm, Ashburn VA http://janelia.hhmi.org
INI, ZUrich http://www.ini.uzh.ch/
Wayne Rasband (ImageJ)

The Fiji Team:
http://fiji.sc/Contributors


http://www.mpi-cbg.de/
http://janelia.hhmi.org/
http://www.ini.uzh.ch/
http://fiji.sc/Contributors
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